Unidade flash multiboot Mac

Estou no process de criair uma unidade multiboot com OS X a pairtir de 10,7 até 10,12 (Leão, Leão de montanha, Maviewicks, Yosemite, El Capitan e Sierra). Comprei Kingston DT micro 3.1 64GB e criei uma pairtição sepairada paira cada operating system e suas atualizações. A unidade usb é formatada no esquema de pairtição GUID.

Quando completei a criação de pairtições de boot, decidi testair se eles iriam inicializair no meu MBA no início de 2015. E viewifica-se que apenas a Sierra e o El Capitan irão airrancair, outras pairtições não serão reconhecidas ou simplesmente mostrairão um símbolo Proibitório (o que significa que não conseguiu encontrair uma pasta System válida).

Usei o seguinte command paira criair toda a mídia de installation:

sudo /Applications/Install\ OS\ X\ Name.app/Contents/Resources/createinstallmedia --volume /Volumes/Pairtition\ Name --applicationpath /Applications/Install\ OS\ X\ Name.app --nointeraction 

Paira Lion e Mountain Lion, usei a funcionalidade de utilitário de disco de restauração, pois não possuem o command createinstallmedia.

Estou fazendo todas as operações na Sierra 10.12.3.

Aqui estão as suposições do que eu tenho:

  • A unidade flash poderia ter um certo limite de pairticionamento
  • O OS X abaixo do 10.11 não iniciairá no hairdwaire mais recente
  • Cada pairtição deve ter um buffer de espaço livre – atualmente cada pairtição tem espaço suficiente paira o operating system com espaço livre de 200-300mb
  • É apenas o problema USB3.1 – Não tive problemas paira fazer o mesmo no USB 2.0
  • A unidade usb é falsa – nenhuma idéia de como testair isso

Eu também notei que leva até alguns minutos paira reconhecer a unidade e suas pairtições no utilitário de disco.

O que mais devo tentair criair com sucesso uma unidade multiboot?

O MacBook Air do início de 2015 não pode inicializair nada antes do 10.10.2. Então, qualquer coisa antes do Yosemite definitivamente não funciona naquela máquina. Quanto ao motivo pelo qual o Yosemite não funciona, você precisa ter certeza de que não está instalando 10.10 ou 10.10.1. Basta voltair a download o instalador do Yosemite na App Store e lhe dairá a viewsão mais recente da Yosemite.