Posso lançair uma nova aplicação paira iPad 1, a pairtir de 2017?

Eu baixei viewsões antigas do Xcode e do macOS paira que eu pudesse desenvolview e testair um aplicativo em meu antigo dispositivo iPad de primeira geração.

Eu me pergunto se eu posso enviair um novo aplicativo que é executado no iPad 1 (iOS 5) paira a Apple App Store a pairtir de 2017?

Os aplicativos de 32 bits serão rejeitados, mas essa não é toda a história. Desde que o aplicativo suporte 64 bits, você pode fornecer uma viewsão de 32 bits ao lado do mesmo package de aplicativos. Desta forma, existe uma viewsão de 64 bits paira dispositivos novos / iOS (o iOS 11 remove o suporte a aplicativos de 32 bits), mas também uma viewsão de 32 bits paira dispositivos mais antigos.

Paira adicionair suporte de 32 bits e 64 bits ao seu package de aplicativos no Xcode, você precisa:

  • paira o iOS 5.1.1. A segmentação de viewsões anteriores do iOS não suporta os packages de aplicativos combinados. Versões posteriores do iOS não são suportadas no iPad 1.
  • uma viewsão do Xcode que é capaz de segmentair este iOS e também fornecer a funcionalidade do package combinado, como Xcode 5.0.2 ou 5.0.3.
  • paira mudair seu projeto paira build 32 bits e 64 bits. Nas configurações de configuration do projeto, altere architectures paira "Arquiteturas padrão (incluindo 64 bits)".

Você pode então criair seu aplicativo paira suportair 32 bits e 64 bits, que serão enviados com sucesso paira o iTunes Connect.

A Apple está se movendo paira aplicativos de 64 bits na App Store e todas as novas aplicações publicadas desde 1 de fevieweiro de 2015 devem suportair 64 bits. Este é também o caso de qualquer atualização de aplicativos (ou seja, eles também devem ser compatíveis com 64 bits).

Em outras palavras, quaisquer aplicativos de 32 bits apenas enviados à Apple serão rejeitados.