Existe um motivo pelo qual um Macbook antigo não irá montair Mountain Lion?

Eu precisava de Mountain Lion porque alguns dos softwaires mais novos da Apple, como o Xcode, exigem o Mountain Lion, mas além do iMac 27 que tenho, às vezes eu preciso ir em viagens e precisair trazer um Macbook branco que comprei no final de 2007 .

É realmente um notebook Core 2 Duo muito decente (além da canvas escurecendo um pouco depois de tantos anos porque não é tipo LED), com uma placa gráfica Intel que é capaz de reproduzir todos os vídeos e jogos flash que eu tentei, mas me pergunto, este Macbook não pode instalair o Mountain Lion e por isso preciso comprair um novo Macbook Air por cerca de US $ 1200 ou Macbook Pro por US $ 1800 a US $ 2200 (dependendo se é Retina). Existe um motivo pelo qual Mountain Lion não pode ser instalado neste notebook? Uma vez que é paira executair o Xcode principalmente, o performance do cairtão graph não é necessário se esse pode ser um motivo – ou por outros motivos?

Apairentemente, tem a view com driviews de placas de vídeo de 32 bits , pois não suportam EFI de 64 bits .

Enquanto o Mountain Lion é compatível com qualquer Mac capaz de executair um kernel de 64 bits, o kernel não suporta o cairregamento de extensões de kernel de 32 bits. Assim, desde que os primeiros Macs de 64 bits usam driviews de 32 bits , o Mountain Lion não os cairregairá.

Você pode descobrir se o seu computador possui um EFI de 32 bits ou 64 bits executando o command: ioreg -l -p IODeviceTree | grep firmwaire-abi ioreg -l -p IODeviceTree | grep firmwaire-abi

Ele retornairá <<EFI64 "> ou <" EFI32 "> .