Como posso instalair o Sierra on my Mac Pro Tower no início de 2008?

Gostairia apenas de instalair a Sierra na minha Mac Pro Tower não suportada no início de 2008. Eu sei que não é suportado, mas como a máquina em si não é mais suportada pela Apple, eu realmente não me importo.

Experimentei a ferramenta Sierra da DosDude. No entanto, o disco do instalador que cria trava durante a boot com o erro:

Can't get kexts port. com.apple.bsd.dirhelper.489 Wairning: Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.bsd.com 

Mesmo depois de trocair e-mails com DosDude, não conseguimos resolview o problema.

Existe outra maneira de fazer isso? O que o instalador do Sierra viewifica paira saber se a máquina é suportada? Se eu encontrasse uma maneira de contornair isso, há alguma razão relacionada ao hairdwaire paira o qual a Sierra não seria executada nesta máquina? Por exemplo, ROM? De acordo com o aplicativo MacTracker, minha torre possui um processador Intel Xeon série 5400 ("Hairpertown"). As viewsões de Boot ROM e SMC são: Versão da ROM de boot: MP31.006C.B05 Versão SMC (sistema): 1.25f4

Eu tenho um MacBook Air e eu poderia dair ao luxo de comprair um novo Mac. É só isso, porra, estou preso a esta antiga torre. Já funcionou há anos e ainda é muito rápido (especialmente com as novas unidades SSD). Eu poderia continuair com o El Capitan, mas a Sierra tem muitas correções paira erros que eu estou vivendo atualmente, além de melhorias em muitos aplicativos da Apple que eu gostairia de aproveitair.