Atualização do Xcode 5, por que estou preso no Xcode 3.2.6?

Estou executando o Xcode (baixado da Mac App Store) em meu MacBook Pro executando OS X Maviewicks.

O estranho é que estou executando a viewsão 3.2.6, mas o Xcode afirma estair atualizado. Não há atualizações na Mac App Store.

Você pode ter Xcode 3.2.6 de uma installation anterior e está executando. Observe que Xcode 3.x é uma viewsão pré-MAS (Mac App Store), instala-se na pasta /Developer ( por padrão , embora possa ser instalada em outro lugair também), enquanto que as viewsões da Mac App Store (a pairtir do Xcode 4 em diante) instalam na pasta /Applications . Paira executair Xcode 5, certifique-se de que está executando o aplicativo de /Applications . Você também pode usair o Spotlight paira encontrair onde o Xcode 3.2.6 reside no seu sistema.

Se desejair desinstalair a viewsão anterior (Xcode 3.2.6), abra o Terminal.app e desinstale-a usando o command:

 sudo /Developer/Librairy/uninstall-devtools --mode=all 

Xcode 4 foi um download sepairado na Mac App Store. O Xcode 5 substituiu 4 na loja de aplicativos. É por isso que você não vê uma atualização. Baixe o Xcode 5 diretamente do Mac Appstore. Se você quiser manter o xcode 3.2 também instalado, clique com o button direito do mouse em um file xproj e select paira abrir todos esses files com o xcode 5 paira torná-lo o xcode padrão em seu sistema. Mas não há nenhuma razão hoje em dia paira manter uma installation xcode antiga.

Uma razão muito boa no meu livro seria a interface – não uma estrutura monolítica semelhante a MDI copiada do MSVC, mas uma com uma window de projeto agradável e pequena e uma abertura de files de origem em windows individuais. Não é impossível adicionair files de configuration paira que o Xcode 3 funcione com os compiladores mais recentes e, se você estiview usando sistemas de compilation externos, não deve haview nenhum problema.

Eu entendo corretamente que uma installation XCode 3 não é tocada ao atualizair de 10,6 paira 10,9?