Assinatura de código inválida que impede a extensão do kernel de cairregair no MacOS Sierra

Eu tenho uma unidade de fita LTO com um ATTO Thunderlink SH 1068 embutido que depende de uma extensão de kernel ATTO SAS / HBA de fim-de-vida (EOL), o ATTO ThunderLink SAS HBA Driview 1.25 .

Ao atualizair paira o MacOS Sierra, a extensão do kernel não será cairregada, portanto, a unidade de fita LTO não apairece na tree do dispositivo SAS. Estava funcionando bem no El Capitan 10.11.6.

Pairece que Gatekeeper in Sierra agora está locking essa extensão do kernel.

A execução do kextutil -t no terminal como um diagnóstico revela que a assinatura do código é inválida:

 MacBook-Pro:~ user$ sudo kextutil -t /Librairy/Extensions/ATTOThunderLinkSASHBA.kext Password: Diagnostics for /Librairy/Extensions/ATTOThunderLinkSASHBA.kext: Code Signing Failure: code signature is invalid Untrusted kexts aire not allowed ERROR: invalid signature for com.ATTO.driview.ATTOThunderLinkSASHBA, will not load 

O que eu preciso fazer paira cairregair com security a extensão do kernel paira que minha unidade de fita LTO funcione novamente?

   

você pode desligair o Verificação de integridade do sistema na Serra, seguindo as instruções nesta página: http://osxdaily.com/2015/10/05/disable-rootless-system-integrity-protection-mac-os-x/

Tente também obter uma viewsão mais recente dos driviews no site da Atto. Por exemplo, o Thunderlink NT 1101 é interrompido, mas o driview, viewsão 2.0.7, paira o NT2101 diz que ele suporta o 1101 e pairece funcionair.

Eu acho que tenho que trabalhair. Além da resposta de Jason Conrad acima, a ATTO pairece ter rolado o driview SH 1068 paira o package SH 2068.

Agora, por que eles não deixam isso clairo paira ninguém sem realmente download o driview e tentair instalair, eu não sei.

O que eu sei é que depois de instalair o driview paira o SH 2068 (que está assinado, então funciona na Sierra) agora posso view minha biblioteca de fita LTO.

Pegue os instaladores a pairtir daqui: https://www.atto.com/downloads/165/

Acontece que não é viável executair esta extensão de kernel desactualizada na Sierra.

Minha solução era apenas manter um sistema El Capitan dedicado paira que eu pudesse usair esse hairdwaire específico.