Alguém já teve problemas com a atualização do Application Loader 2.5.1?

O problema é que a Atualização de Softwaire me sugere instalair o Application Loader 2.5.1, mas cada vez que estou tentando instalá-lo, o 71.4 disturb é baixado e o instalador lança um erro "A atualização" Application Loader "não pode ser instalada. Um erro ocorreu".

Mais uma coisa é instalada sem problemas. Onde devo começair por resolview este problema?